The International Simutrans Forum

 

Author Topic: Mysterious steel mill bug with pak128.Britain/Experimental  (Read 3640 times)

0 Members and 1 Guest are viewing this topic.

Offline neroden

  • Devotees (Inactive)
  • *
  • Posts: 831
  • Nathanael Nerode
Mysterious steel mill bug with pak128.Britain/Experimental
« on: March 20, 2010, 08:41:33 AM »
This may be a pak bug or an Experimental bug.

Current simutrans-experimental (simutrans-exp-2010-01-28-6c9a8b9),
pak128Britain_1-0-7_0-102, based off simutrans 102.2.2.

In 1804 the Steel Mill shows up.  It's happy to eat my coal and iron, but it produces no steel at all, ever.  :-(  This is rather unfortunate.

The savegame is here:
http://files.simutrans.us/files/get/Ur-p3-A5_B/ex-1804-no-steel.sve



Offline Brambo

  • *
  • Posts: 44
Re: Mysterious steel mill bug with pak128.Britain/Experimental
« Reply #1 on: May 24, 2010, 01:27:21 PM »
I had this bug in Experimental 7.3 with pak128.britain 1.07 standard, also with a (newly spawned) steel mill. I played with timeline off and I have a savegame if needed.
« Last Edit: May 24, 2010, 01:34:18 PM by Brambo »

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18745
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Mysterious steel mill bug with pak128.Britain/Experimental
« Reply #2 on: May 24, 2010, 09:42:15 PM »
Thank you for the reports, and apologies to Nathaneal for having missed this earlier. Can you both re-test with Simutrans-Experimental 8.0?

Offline Brambo

  • *
  • Posts: 44
Re: Mysterious steel mill bug with pak128.Britain/Experimental
« Reply #3 on: May 24, 2010, 09:49:37 PM »
Well, upgrading to 8.0 did not fix the save game, the mill is still a black hole.
Of course, my savegame could now be bugged and the bug gone, but since I do not know how to reproduce the bug, I guess it's just waiting to see whether it will pop up during playing.

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18745
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Mysterious steel mill bug with pak128.Britain/Experimental
« Reply #4 on: May 24, 2010, 10:53:32 PM »
Brambo,

can you post the saved game? I may not have time to look at it until I get back from holiday next week, but I'd be grateful to see the saved game so that I can try to diagnose the problem. Thank you for the report :-)

Offline Brambo

  • *
  • Posts: 44
Re: Mysterious steel mill bug with pak128.Britain/Experimental
« Reply #5 on: June 05, 2010, 12:02:02 PM »
Here is the savegame (37mb). The steel mill near Llandudno never receives the delivered goods.

http://www.megaupload.com/?d=JO6DSYK7

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18745
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Mysterious steel mill bug with pak128.Britain/Experimental
« Reply #6 on: June 05, 2010, 04:51:16 PM »
Brambo,

thank you for the upload - that is helpful. I can reproduce the problem in your saved game, but not with a new game. This is especially mysterious, however, since the code for industries consuming goods has not been touched at all in the changes between Standard and Experimental, so it's very odd indeed. I'm having trouble tracking this one down, I'm afraid...

Offline Brambo

  • *
  • Posts: 44
Re: Mysterious steel mill bug with pak128.Britain/Experimental
« Reply #7 on: June 06, 2010, 11:26:25 PM »
Hi,

Just came across the same(?) bug: a Bakery, which had existed from the beginning and processed goods without problems, suddenly became a black hole for flour. I'm still playing exp 7.3 (8 is just not playable right now) with pak128.Britain 1.07 standard.

I have an older save where it is still working (game year 1963). Here is the save from 3 years later, where it isn't (the bakery is in Ipswich):

http://www.megaupload.com/?d=N0RTQMSP


Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18745
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Mysterious steel mill bug with pak128.Britain/Experimental
« Reply #8 on: June 07, 2010, 12:10:06 AM »
Brambo,

thank you for the report. This is a very curious problem. I'll have a look at your saved game when I have time, but, in the meantime, have you tried Experimental 8.1, released earlier to-day? It fixes many of the issues in Simutrans-Experimental 8.0.

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18745
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Mysterious steel mill bug with pak128.Britain/Experimental
« Reply #9 on: June 26, 2010, 11:43:23 PM »
At last, I have tracked down and fixed this error. Fix about to be pushed to the 8.x branch on Github, and should be included with the next release. Thank you for the reports!

Offline Brambo

  • *
  • Posts: 44
Re: Mysterious steel mill bug with pak128.Britain/Experimental
« Reply #10 on: June 27, 2010, 10:22:54 AM »
That's great news, James! Thanks!

EDIT: it truly appears to have worked! thanks!
« Last Edit: June 27, 2010, 06:11:14 PM by Brambo »