The International Simutrans Forum

 

Author Topic: "Show unread posts" problem again  (Read 2548 times)

0 Members and 1 Guest are viewing this topic.

Offline isidoro

  • Devotee
  • *
  • Posts: 1137
"Show unread posts" problem again
« on: April 23, 2020, 09:47:06 PM »
Hi, I quite remember some time ago of having problems with the "Show unread posts since your last visit" forum link.
It seems that now, it happens again.  When clicking on it, the list appears empty, while there are certainly new unread posts.
Investigating a little, the link I follow from the forum is:https://forum.simutrans.com/index.php?action=unread;c=2
But, if I delete the ";c=2" part, it seems to work.  But all this is arcane to me.   ???
Just in case it helps.
 

Offline Freahk

  • Devotee
  • *
  • Posts: 1353
  • Languages: DE, EN
Re: "Show unread posts" problem again
« Reply #1 on: April 23, 2020, 10:06:21 PM »
I frequently have quite simmilar issues with this forum. Pages sometimes seem to get loaded from browser cache, although the content had changed.
Did you try to enforce reloading from the server? In most browsers this is strg + f5.
This fixed quite a lot  issues with the forum for me.

Offline Isaac Eiland-Hall

  • Benevolent Dictator
  • Administrator
  • *
  • Posts: 3861
  • Providing hosting for Simutrans projects
    • pc2.io
  • Languages: EN
Re: "Show unread posts" problem again
« Reply #2 on: April 24, 2020, 05:14:52 PM »
Odd. For me, "Unread posts" link points to https://forum.simutrans.com/index.php?action=unread

And from there, when there are no posts, the link to "all unread posts" appears which is https://forum.simutrans.com/index.php?action=unread;all;start=0 — which is also what I long ago bookmarked to visit from my favorites.

I've verified forum caching options are already disabled. I've just unchecked "Allow browsers to go back to cached pages" just to see if that helps, although I suspect it won't - but let me know.

I wonder where that parameter comes from. I've just taken a look at admin and personal settings and I don't see anything that would make sense. :/

Offline isidoro

  • Devotee
  • *
  • Posts: 1137
Re: "Show unread posts" problem again
« Reply #3 on: April 24, 2020, 09:44:33 PM »
Sorry, my fault.
The problem seems to come from my bookmarking of the wrong link.  There are links for unread posts for every subforum and a link for all subforums, which matches the one you pointed out.  The general link is just at the beginning of the page and I overlooked it...  :-[
I was just bookmarking the link from "Information and Announcements".
I guess that the "c" parameter is used when you want to restrict you search for a subforum.r

Thanks both of you for your help.


Offline Isaac Eiland-Hall

  • Benevolent Dictator
  • Administrator
  • *
  • Posts: 3861
  • Providing hosting for Simutrans projects
    • pc2.io
  • Languages: EN
Re: "Show unread posts" problem again
« Reply #4 on: April 25, 2020, 12:41:18 AM »
:whew:

Still doesn't solve caching, but that surely must be on the browser side. :/