The International Simutrans Forum

 

Author Topic: Commercial building problem  (Read 6073 times)

0 Members and 1 Guest are viewing this topic.

Offline joosep93

  • *
  • Posts: 11
Commercial building problem
« on: February 13, 2011, 01:08:35 PM »
I have a problem with this com building. I think it's something wrong with dat file.
Please help
This is my first addon.

Offline mobo

  • Devotees (Inactive)
  • *
  • Posts: 199
Re: Commercial building problem
« Reply #1 on: February 13, 2011, 02:38:58 PM »
Obj=building
Name=HOTEL_MANSION
copyright=Joosep
Type=com
Level=20
chance=100
intro_year=2000
climates=tropic,mediterran,temperate,tundra,rocky,arctic
BackImage[0][0][0][0][0][0]=com_100.0.0
--------------------

Your building is only 1 tile high so you need only one Backimage line
also it's 6 times
Code: [Select]
[0] now but 5 might also still work

also spaces in the name might cause problems so try a _

intro year 2000 is rather late, be sure to start with corresponding settings (or timeline off)

Looks nice Btw, i like it!

Offline VS

  • Senior Plumber (Devotee)
  • Devotee
  • *
  • Posts: 4855
  • Vladimír Slávik
    • VS's Simutrans site
  • Languages: CS,EN
Re: Commercial building problem
« Reply #2 on: February 13, 2011, 02:54:39 PM »
mobo: You use "com_100" but the file is actually called only "com"...

Offline mobo

  • Devotees (Inactive)
  • *
  • Posts: 199
Re: Commercial building problem
« Reply #3 on: February 13, 2011, 03:21:14 PM »
Right, the filename has to be correct too, didn't notice that.

...com_100.0.0 points to image com_100.png, so change filename or dat to make them match.

Offline joosep93

  • *
  • Posts: 11
Re: Commercial building problem
« Reply #4 on: February 13, 2011, 03:42:56 PM »
Okey I did it and it worked. But my png needs little change because the blue background won't disappear in game.

Offline VS

  • Senior Plumber (Devotee)
  • Devotee
  • *
  • Posts: 4855
  • Vladimír Slávik
    • VS's Simutrans site
  • Languages: CS,EN
Re: Commercial building problem
« Reply #5 on: February 13, 2011, 04:01:51 PM »
It should be 231,255,255 or e7ffff. You currently have 234,254,253.

Offline joosep93

  • *
  • Posts: 11
Re: Commercial building problem
« Reply #6 on: February 13, 2011, 04:30:25 PM »
Done. Thanks for helping me.

Offline Václav

  • Devotee
  • *
  • Posts: 3266
  • formerly VaclavMacurek
  • Languages: CZ, EN
Re: Commercial building problem
« Reply #7 on: February 14, 2011, 01:57:11 PM »
Looks very interesting - but: see I right it is made for pak64? Why don't try to make it also for pak128?

Offline joosep93

  • *
  • Posts: 11
Re: Commercial building problem
« Reply #8 on: February 14, 2011, 07:27:35 PM »
As you wish VaclavMacurek. Here is one for pak128

Offline Václav

  • Devotee
  • *
  • Posts: 3266
  • formerly VaclavMacurek
  • Languages: CZ, EN
Re: Commercial building problem
« Reply #9 on: February 14, 2011, 09:08:34 PM »
Thank you very much. I will test it as soon as possible.

Those white spots can be removed with GIMP - but it is needed to use extreme zoom (400% or more) and to know which colour causes those white spots - but it is quite (not very, only quite) easy to see that colour.