The International Simutrans Forum

 

Author Topic: Pak-loading troubles  (Read 1880 times)

0 Members and 1 Guest are viewing this topic.

Offline Junna

  • Devotee
  • *
  • Posts: 1082
Pak-loading troubles
« on: March 26, 2011, 07:48:59 PM »
I am not certain this is the right place, but I was unable to think of a place more proper.

I have major trouble at times loading my common-use pak, which is a mixture of pak128 786 version and a lot of addons; at first I thought this was due to some limit in the total amount of files allowed (it's currently at 4550 files and 315/25 mb). At first I thought this was some problem with specific paks but it seems to be irrelevant and happen no matter what.

Quote
Calculating textures ... FATAL ERROR: realloc()
Could not alloc 0 bytes

I also tried to remove one file and add another of a different kind, but this also leads to a crash.
I have tested this on 110.0.0.1, 110.0, Exp. 9.3, as well as 110 r4381, and the result is the same.

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4601
  • Languages: EN, DE, AT
Re: Pak-loading troubles
« Reply #1 on: March 26, 2011, 08:44:19 PM »
Seems to be some kind of out-of-memory error. Does this happen with smaller paksets too (eg standard pak64) ?

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 9565
  • Languages: De,EN,JP
Re: Pak-loading troubles
« Reply #2 on: March 26, 2011, 09:09:45 PM »
Maybe you have added some old ground.xyz.pak? The can happen especially if the lightmap is of height zero. Or you might have too many object (more than 65534 images).

Unfourtunatly those could be also part of bigger paks. (pak128 has its pak actually as pak of pak. You can use "makeobj EXTRACT" to create those single paks from the archieve.)

EDIT: However, putting all pak128 object together (pak128, jap128.japan, pak128.german, pak128.britain, and all japanese and hongkong addons I could could get (well some train missing) I could not exceed 5000 images. And that is some extreme mixture.
« Last Edit: March 26, 2011, 09:40:28 PM by prissi »

Offline Junna

  • Devotee
  • *
  • Posts: 1082
Re: Pak-loading troubles
« Reply #3 on: March 26, 2011, 11:59:05 PM »
Maybe you have added some old ground.xyz.pak? The can happen especially if the lightmap is of height zero.

How would I find if I do have an old ground version? I think the pak128 development stopped soon after anyway.

http://www.mediafire.com/?deeebo8zerswp7g

Here's the pak in question, at it's non-crashing point. Try add a few more paks of any kind and it seems to start crashing.

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4601
  • Languages: EN, DE, AT
Re: Pak-loading troubles
« Reply #4 on: March 27, 2011, 01:44:32 PM »
With the recent nightly, you will get a better error message. But not more :/ You have too many images loaded (too many pak files).