The International Simutrans Forum

 

Author Topic: [intended behavior] Impossible to build railway signals on switches.  (Read 2246 times)

0 Members and 1 Guest are viewing this topic.

Offline aliesperet

  • *
  • Posts: 15
A few days ago i downloaded simutrans 110.0.1, and today i began to work with it (Pak.128). But as soon as i began to build the first problem appeared: it seems impossible to build railway signals on switches. I immediately got the save file from my old version 102.2.2 and then it got even stranger. The old signals-on-switches were still there (and working) but i could not built any new signals on switches. My question is: Why can't i do that anymore? And if it is an error, could you make sure it is possible in a newer version?
« Last Edit: January 21, 2012, 10:03:26 AM by Dwachs »

Offline Combuijs

  • Web Team
  • Devotee
  • *
  • Posts: 1408
  • Maintainer of maps.simutrans.com
    • Combuijs
  • Languages: EN, NL
Re: [110.0.1] Impossible to build railway signals on switches.
« Reply #1 on: April 01, 2011, 01:08:12 PM »
Hmm, I never build signals on switches, because I don't know what they will do...

Offline VS

  • Senior Plumber (Devotee)
  • Devotees (Inactive)
  • *
  • Posts: 4856
  • Vladimír Slávik
    • VS's Simutrans site
  • Languages: CS,EN
Re: [110.0.1] Impossible to build railway signals on switches.
« Reply #2 on: April 01, 2011, 02:58:35 PM »
The big issue is that signals face a direction, and on a junction (switch) you don't have "front" and "back". So, the behaviour is undefined, perhaps even to some extent rotation dependent, which would be a bug in itself.

To put it in proper terms, on a graph of railway trackage, signals of the currently used kind belong on edges, not nodes.

So, I think it is better to get rid of signals on junctions completely...

There are only two proper alternatives: Putting signals on tile borders, and/or being able to specify which tile sides are fronts and which backs. The former was originally used and abandoned a few years ago. (Probably for some good reason?) The latter increases complexity of signalling and makes the rules less obvious yet again, which is not a good perspective either.

edit: I don't actually know if the change was intentional, but I really hope so :)
« Last Edit: April 01, 2011, 03:10:43 PM by VS »

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 10682
  • Languages: De,EN,JP
Re: [110.0.1] Impossible to build railway signals on switches.
« Reply #3 on: April 03, 2011, 06:13:31 PM »
Your were never allowed to build signals on switches. You could although built switches on signal ... Those signals will work, but trains will stop on tiles without a signal. This is mostly a graphics issue.

This behaviour was introduced due to the new path based signalling. In retrosight, this could have been realized also with signals on tile borders, if trains from north-east would stop a tile earlier than from south west.