The International Simutrans Forum

 

Author Topic: [r4780] Trucks stopping several tiles before choose signs  (Read 1977 times)

0 Members and 1 Guest are viewing this topic.

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 5695
  • Languages: EN, NO
[r4780] Trucks stopping several tiles before choose signs
« on: August 18, 2011, 08:29:47 PM »
I just noticed some strange new behavior with trucks and choose signs. A truck was waiting for clearance on a tile before a road junction before a tile with a choose sign, despite the fact that there is a free freight yard beyond the choose sign. Once the other, occupied, freight yard becomes free, the truck starts moving. This is troublesome behavior, as the waiting truck might block other traffic.

I have uploaded a save game that demonstrates the behavior. One truck is seen waiting immediately upon loading the game. It soon starts moving. To see the situation develop, head over to Pinefield freight yard, where a grain truck coming from the north will stop too soon early next game month.

The save game can be found at http://simutrans-germany.com/files/upload/Ters_4_-_truckchoose.sve Note that the game still suffers after effects from the change in passenger destination distribution a while back, so lots of overcrowding going on.
« Last Edit: August 19, 2011, 12:15:38 AM by IgorEliezer »

Offline TurfIt

  • Dev Team, Coder/patcher
  • Devotee
  • *
  • Posts: 1447
Re: [r4780] Trucks stopping several tiles before choose signs
« Reply #1 on: August 18, 2011, 11:47:49 PM »
Should be fixed with r4783.

Nice looking map!
Note that the game still suffers after effects from the change in passenger destination distribution a while back, so lots of overcrowding going on.
Setting locality_factors to 10000 and factory_enforce_demand=0 will result in similar behaviour to before the changes...

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 5695
  • Languages: EN, NO
Re: [r4780] Trucks stopping several tiles before choose signs
« Reply #2 on: August 19, 2011, 08:33:57 AM »
Thanks.

Setting locality_factors to 10000 and factory_enforce_demand=0 will result in similar behaviour to before the changes...

I'm not interested in the old behavior. I've also gotten past the worst part of the transition, so I don't want to upset the network once again.