The International Simutrans Forum

 

Author Topic: Misc 10.0 error: loading xml saves  (Read 1738 times)

0 Members and 1 Guest are viewing this topic.

Offline Carl

  • Devotee
  • *
  • Posts: 1599
    • Website
  • Languages: EN
Misc 10.0 error: loading xml saves
« on: August 27, 2011, 09:49:46 AM »
Here's a minor issue with the 10.0 branch that I didn't think worth including in the main pre-release topic, but nevertheless seemed worth reporting for the record.

10.0 is unable to open most saves made in xml format. It gives the following error:

Code: [Select]
FATAL ERROR:
loadsave_t::start_tag()
expected "tunnelboden_t",
got "grund_t>
     รป []"

Note that the "[]" here is a square box in the error. This error does not occur in other save formats.

The problem doesn't seem to be with the saves themselves. I tried making an xml save of a game in 9.12 and then opening it with 9.12, and this was successful. However, this 9.12-created xml save could not be opened in 10.0. Similarly, xml saves created in 10.0 give rise to the same error.

I can reproduce via the following steps:
1. Set save format to xml in simuconf.tab
2. Start a new map
3. Build a tunnel
4. Save the map and close Simutrans
5. Open Simutrans and load the save map
6. Error!


Here's a pak128Britain.ex 0.8 save to demonstrate: http://dl.dropbox.com/u/61716/tunnel.rar
« Last Edit: August 27, 2011, 09:54:58 AM by carlbaker »

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18721
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Misc 10.0 error: loading xml saves
« Reply #1 on: August 27, 2011, 03:14:49 PM »
Hmm, that's very odd - I haven't changed anything specific to XML saving between 9.12 and 10.0. I wonder whether this is a bug from the latest Standard nightlies...?