The International Simutrans Forum

 

Author Topic: [10.11] Map generation and enlargement problems  (Read 1227 times)

0 Members and 1 Guest are viewing this topic.

Offline ӔO

  • Devotees (Inactive)
  • *
  • Posts: 2345
  • Hopefully helpful
  • Languages: en, jp
[10.11] Map generation and enlargement problems
« on: October 01, 2012, 05:58:58 AM »
Something doesn't seem to be working right with the map generation settings.

If you start off with map number 9021, and give it W-E: 640 and N-S: 256, you should end up with the same map generated in standard. However, when you increase W-E to 768, a completely different map emerges.

Now, if you take that 640x256 map, flip it 180degrees and enlarge it, something weirder will happen. Attached below is the result. Try the same thing in standard, and the map will look very different from the experimental map.

There is a cattle farm on here that has managed to generate itself inside the sea.
http://dl.dropbox.com/u/17111233/Stag.rar

To me, it looks like some kind of data corruption.

Offline jamespetts

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 20268
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: [10.11] Map generation and enlargement problems
« Reply #1 on: October 01, 2012, 11:15:13 AM »
I am not sure about aquatic cattle farms - I haven't had chance to look at the map yet, but the different generation from Standard on larger maps is intentional so as to make larger maps scape better - with the Standard settings, large maps are too fussy and do not look like the real world (there are insufficient seas and too many lakes).