The International Simutrans Forum

 

Author Topic: [patch] Allegro hardware mouse pointer support  (Read 2300 times)

0 Members and 1 Guest are viewing this topic.

Offline swed

  • *
  • Posts: 33
  • Languages: EN, FR
[patch] Allegro hardware mouse pointer support
« on: April 18, 2012, 07:21:27 PM »
Hello!

Actually, when using allegro backend, mouse pointer is emulated by software (USE_SOFTPOINTER flag is automatically set in MakeFile).

Using the hardware pointer is nicer, and more comfortable in my opinion, and that's why I made this small patch.

Now, I can use the hardware pointer, or use the software one if I set the flag manually.

Hope that will be useful for someone !
Bye ;)

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 10829
  • Languages: De,EN,JP
Re: [patch] Allegro hardware mouse pointer support
« Reply #1 on: April 18, 2012, 07:52:35 PM »
All the allegro version I have access do not support hardware pointer. That is why there was only software.

Offline swed

  • *
  • Posts: 33
  • Languages: EN, FR
Re: [patch] Allegro hardware mouse pointer support
« Reply #2 on: April 18, 2012, 08:17:35 PM »
For info, I tested with allegro 4.4.0.1 and it's ok.
(maybe depends on the OS too?)

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 10829
  • Languages: De,EN,JP
Re: [patch] Allegro hardware mouse pointer support
« Reply #3 on: April 18, 2012, 09:18:40 PM »
Ok, I will test it. Maybe I did something wrong the last time this was used (which was still allegro 3.x)