The International Simutrans Forum

 

Author Topic: "The Operation Completed Successfully [] "  (Read 1889 times)

0 Members and 1 Guest are viewing this topic.

Offline AP

  • Devotee
  • *
  • Posts: 1202
  • Languages: EN
"The Operation Completed Successfully [] "
« on: December 11, 2012, 07:09:02 PM »
Here's an odd one. When I try to connect to the server game in the current way (load game "net:bridgewater-brunel.me.uk") - sometimes (and tonight, all the time) it fails to load, and pops up with a "Message" box, with the red triangle exclamation mark graphic, and "The operation completed successfully [] " (where the [] is actually a rectangular symbol i presume in lieu of something the font can't display).

Obviously, the operation did not in fact complete successfully, since behind the message is the demo.sve game.

No idea what's going on, or what it think *did* complete successfully, but it's a bit odd, no?

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18502
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: "The Operation Completed Successfully [] "
« Reply #1 on: December 11, 2012, 11:42:32 PM »
Hmm, it's an odd error message, I know. The code relating to this has not been changed from Standard, so I don't know quite why it is so structured. I know that the code for joining servers is different in the newer versions of Standard, and also in the 112.x merge branch on which Bernd has been working recently. I am hoping that that branch will have a more useful error message.

The (incorrect) message appears when the server is busy (for example, if somebody else is in the process of joining) when you try to join. I have just got into the network game, so this is not appearing now. Are you now able to get in, too?

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 9438
  • Languages: De,EN,JP
Re: "The Operation Completed Successfully [] "
« Reply #2 on: December 13, 2012, 01:26:17 PM »
This is a wiondows messgae, when the IP does not answer. Windows indicate and error state and when asking dfor the error message it returns this. Very stupid, but nothing I can do about.

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18502
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: "The Operation Completed Successfully [] "
« Reply #3 on: December 14, 2012, 01:21:40 AM »
Hmm. Windows bug, not Simutrans bug. Perhaps we could have a workaround that checks for this specific message and replaces it with something useful instead...?

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 9438
  • Languages: De,EN,JP
Re: "The Operation Completed Successfully [] "
« Reply #4 on: December 14, 2012, 02:40:01 PM »
The message come in your national language. One could check for the error code though.

Offline ӔO

  • Devotees (Inactive)
  • *
  • Posts: 2345
  • Hopefully helpful
  • Languages: en, jp
Re: "The Operation Completed Successfully [] "
« Reply #5 on: December 14, 2012, 05:12:45 PM »
This happens when the server is still in the process of someone else joining, when your client tries to join as well.

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 9438
  • Languages: De,EN,JP
Re: "The Operation Completed Successfully [] "
« Reply #6 on: December 14, 2012, 11:42:25 PM »
Just now no server does this to reproduce it ;)