The International Simutrans Forum

 

Author Topic: Scripting in Experimental  (Read 1302 times)

0 Members and 1 Guest are viewing this topic.

Offline zook2

  • *
  • Posts: 321
Scripting in Experimental
« on: November 28, 2014, 09:13:53 PM »
Just FYI: Both ny911 and I tested a small script with Experimental and the Squirrel API function new_month () doesn't get called. Without new_month (), I don't see a way of performing regular checks for goods transported etc, which means scripting is pretty much broken at the moment. .

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18565
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Scripting in Experimental
« Reply #1 on: November 28, 2014, 10:07:06 PM »
Thank you for letting me know. Scripting, as indicated earlier, is untested in Experimental (apart from your test just now). If anyone would like to look into the code and find a fix for this, it would be most helpful. I do not know, however, how extensive that the work in finding the problem will have to be.

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4564
  • Languages: EN, DE, AT
Re: Scripting in Experimental
« Reply #2 on: November 29, 2014, 08:25:50 PM »

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18565
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Scripting in Experimental
« Reply #3 on: November 29, 2014, 08:56:55 PM »
Hmm - those things are already in Experimental (at least, the way-improvements branch on Github). Was it 11.35 or the way-improvements branch that you were using?