The International Simutrans Forum

 

Author Topic: Clock Speed? My game clock is running very fast  (Read 3549 times)

0 Members and 1 Guest are viewing this topic.

Offline maanlicht

  • *
  • Posts: 9
  • Languages: EN
Clock Speed? My game clock is running very fast
« on: November 07, 2015, 02:46:45 PM »
Any1 noticed the game clock speed is very fast?

I looked in the simutab file and there is no bits_per_month setting, is this right?

I did try to add this setting with 18 but it made no difference to the clock speed.

Days go very quickly.

Any1 have an explanation.

Btw I am running simutrans under wine on a linux pc.

I find the 192 comic pakset brilliant, I play it all the time. Thank you to all involved in this ... you guys are the best !!!!


Maan

Offline Sarlock

  • Devotee
  • *
  • Posts: 1340
  • Languages: EN
Re: Clock Speed? My game clock is running very fast
« Reply #1 on: November 07, 2015, 04:45:35 PM »
Should be in your simuconf.tab file:

bits_per_month = xx

22 or 23 makes for a pretty slow game clock.

Ensure you're editing the simuconf.tab file inside your pakset /config folder.

Offline maanlicht

  • *
  • Posts: 9
  • Languages: EN
Re: Clock Speed? My game clock is running very fast
« Reply #2 on: November 08, 2015, 03:42:18 PM »
Thanks for the reply Sarlock.

That's exactly what I did - No change to clock speed.

I also tried a diff pakset and that was the same fast clock so could it be the new version of Simutrans?

Simutrans 120.0 r7175 is the version I am running

maan




Offline Sarlock

  • Devotee
  • *
  • Posts: 1340
  • Languages: EN
Re: Clock Speed? My game clock is running very fast
« Reply #3 on: November 08, 2015, 04:48:34 PM »
I wonder... are you trying to change the speed on an existing saved game?  If so, you have to change it another way.

In your menuconf.tab file in your pakset's config folder, in the section for dialog_tool entries, there will be one for 27 that is likely commented out with a #.

Change it to:

dialog_tool[27]=27,~

Or change ~ to any other key you want to bind to this command.

Now open back up your save game and press ~ (or whatever key you assigned) and you will get the settings menu.  You can change bits per month there.  Then, all you need to do is save the file, then reload it and it will start with the changed speed setting.

Offline maanlicht

  • *
  • Posts: 9
  • Languages: EN
Re: Clock Speed? My game clock is running very fast
« Reply #4 on: November 09, 2015, 02:41:53 PM »
Oh my, you are a genious ...... brilliant - it worked 1st time

Thank you so much.

Now I can enjoy my games as before

Cheers my friend

maan

Offline [CC206]Ve001

  • *
  • Posts: 1
  • Languages: English,Indonesian
Re: Clock Speed? My game clock is running very fast
« Reply #5 on: February 25, 2016, 01:51:13 PM »
i have a similar problem, but i can't find the dialog box 27 in the menuconf.tab. anyone can help me?

Offline DrSuperGood

  • Dev Team
  • Devotee
  • *
  • Posts: 2709
  • Languages: EN
Re: Clock Speed? My game clock is running very fast
« Reply #6 on: February 25, 2016, 05:09:10 PM »
Quote
i have a similar problem, but i can't find the dialog box 27 in the menuconf.tab. anyone can help me?
You manually add it to the file. The file is dynamically parsed when the pakset is loaded so it will detect the new "dialog_tool[27]=27,~" line in it next time you start the game and the pakset.