The International Simutrans Forum


Author Topic: "Revenue" in (from "Gewinn") should be "Profit"  (Read 384 times)

0 Members and 1 Guest are viewing this topic.

Offline wlindley us

  • Devotee
  • *
  • Posts: 960
    • Hacking for fun and profit since 1977
  • Languages: EN, DE
"Revenue" in (from "Gewinn") should be "Profit"
« on: December 25, 2018, 05:30:01 PM »
In line 2180 "Revenue" should be "Profit" … otherwise in the Line Management dialogue, the top total and each individual convoy can have negative "Revenue" -- clearly impossible.

In gui/, the variable (see line 657) indeed is called "profit" so the translation is simply incorrect.
I would open a pull request but -- what is the correct protocol? Surely not creating a new branch for each of these minor changes, and we don't have write access to Master branch do we?

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18502
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: "Revenue" in (from "Gewinn") should be "Profit"
« Reply #1 on: December 25, 2018, 05:54:53 PM »
Splendid, thank you for spotting that: now fixed.

As to branches - you do not need to create a new branch for each fix, as you can simply push to the master branch on your own repository, which I can then merge.