The International Simutrans Forum

 

Author Topic: Images of vehicles no longer appear in "message center"  (Read 1361 times)

0 Members and 1 Guest are viewing this topic.

Offline Yona-TYT ve

  • Devotee
  • *
  • Posts: 1232
    • Simutrans-BLOG
  • Languages: ES
Images of vehicles no longer appear in "message center"
« on: July 14, 2019, 03:48:28 PM »


The image of the vehicles should appear when you open a message of: New vehicle now available: "vehicle name"

I was testing the scenario tutorial, and I noticed this error, I guess it was when I updated the code of the gui.

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4603
  • Languages: EN, DE, AT
Re: Images of vehicles no longer appear in "message center"
« Reply #1 on: July 15, 2019, 06:30:33 AM »
Which version/revision of the program is affected?

Offline Yona-TYT ve

  • Devotee
  • *
  • Posts: 1232
    • Simutrans-BLOG
  • Languages: ES
Re: Images of vehicles no longer appear in "message center"
« Reply #2 on: July 15, 2019, 06:33:42 AM »
Simutrans 120.4.1 r8776

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4603
  • Languages: EN, DE, AT
Re: Images of vehicles no longer appear in "message center"
« Reply #3 on: July 20, 2019, 09:46:43 AM »
I cannot reproduce this

Offline Yona-TYT ve

  • Devotee
  • *
  • Posts: 1232
    • Simutrans-BLOG
  • Languages: ES
Re: Images of vehicles no longer appear in "message center"
« Reply #4 on: July 20, 2019, 04:37:55 PM »
I cannot reproduce this
I cannot reproduce this
It seems that the first 6 or 7 messages on the list show the images correctly, the rest do not

Offline Yona-TYT ve

  • Devotee
  • *
  • Posts: 1232
    • Simutrans-BLOG
  • Languages: ES
Re: Images of vehicles no longer appear in "message center"
« Reply #5 on: July 21, 2019, 10:27:26 PM »
Maybe it's just in my savegame.

You can check this:
Tutorial3.sve

Offline Yona-TYT ve

  • Devotee
  • *
  • Posts: 1232
    • Simutrans-BLOG
  • Languages: ES
Re: Images of vehicles no longer appear in "message center"
« Reply #6 on: September 22, 2019, 07:53:53 PM »
Now I can replicate the problem!

It turns out that if the message is opened for the first time, the image of the vehicle appears normally.

To replicate save the game, load savegame again and when opening the message the image is no longer displayed.

Edit.
The error is that the message is duplicated when the game is saved and loaded again.

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4603
  • Languages: EN, DE, AT
Re: Images of vehicles no longer appear in "message center"
« Reply #7 on: October 09, 2019, 03:55:58 PM »
Saving & reloading messages loses the information about image. This is hard to fix.

Offline Yona-TYT ve

  • Devotee
  • *
  • Posts: 1232
    • Simutrans-BLOG
  • Languages: ES
Re: Images of vehicles no longer appear in "message center"
« Reply #8 on: October 15, 2019, 02:24:09 AM »
I have saved and loaded a savegame 10 times, and the result was 10 messages repeated in the "message center".  :o :o :o :o

Savegame: https://www.mediafire.com/file/7qts42tkl5znnv2/replicate.sve/file


Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 9568
  • Languages: De,EN,JP
Re: Images of vehicles no longer appear in "message center"
« Reply #9 on: October 15, 2019, 11:48:27 AM »
I presume you just save moments before retirement.

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 5543
  • Languages: EN, NO
Re: Images of vehicles no longer appear in "message center"
« Reply #10 on: October 15, 2019, 02:26:22 PM »
When you load a game, generation of all timeline related messages valid for the current month will be triggered. So if you save and load a game nine times during a single game month, you get ten messages. Nice to have in case the month changed right before you saved. Otherwise, one might miss them. Especially if using autosave on close.