The International Simutrans Forum

 

Author Topic: Experimental 3.4 crashes  (Read 5273 times)

0 Members and 1 Guest are viewing this topic.

Offline Colin

  • Devotees (Inactive)
  • *
  • Posts: 663
  • Certa Cito
Experimental 3.4 crashes
« on: May 05, 2009, 07:13:32 PM »
Hi James,

I'm coming across some problems with 3.4 (may have been with others too) They are only minor and one I've reported elsewhere.

1. Rotating map causes crash. (Not always, seems to be certain locations only)
2. Trying to remove certain Substations causes crash with this error: Runtime Error R6205 Pure Virtual Function Call.(Again not always)
3. Crash when trying to remove underground tracks. (Not all the time, seems to be random)


Best Regards

Colin
« Last Edit: May 05, 2009, 09:50:11 PM by Colin »

knightly

  • Guest
Re: Experimental 3.4 crashes
« Reply #1 on: May 05, 2009, 07:25:02 PM »
2. Trying to remove certain Substations causes crash with this error: Runtime Error R6205 Pure Virtual Function Call.(Again not always)

I also experienced this problem once.

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18690
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Experimental 3.4 crashes
« Reply #2 on: May 05, 2009, 07:43:27 PM »
Colin,

can you post a saved game in which you are having these troubles so that I can look into it? Thank you.

James

Offline rainer

  • SMSC winner
  • *
  • Posts: 100
Re: Experimental 3.4 crashes
« Reply #3 on: May 05, 2009, 08:14:43 PM »
Crashes confirmed.

Sorry, up to now no chance to isolate or reproduce them here. From time to time it crashes even when no user action is done.

Offline Colin

  • Devotees (Inactive)
  • *
  • Posts: 663
  • Certa Cito
Re: Experimental 3.4 crashes
« Reply #4 on: May 05, 2009, 09:49:39 PM »
Colin,

can you post a saved game in which you are having these troubles so that I can look into it? Thank you.

James

Sure thing James. Do you want it to go to simutrans_germany.com?

Regards

Colin
PS: I'm removing the one re the train station, I discovered that the last platform was picking up another station name. The rail stations are underground and for some reason, instead of continuing with the original name it picked up the name of a Tram station above the ground.

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18690
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Experimental 3.4 crashes
« Reply #5 on: May 05, 2009, 10:04:39 PM »
Yes, files.simutrans-germany.com, please. Thank you for the update - one bit of work less for me!

Offline Colin

  • Devotees (Inactive)
  • *
  • Posts: 663
  • Certa Cito
Re: Experimental 3.4 crashes
« Reply #6 on: May 06, 2009, 12:26:05 AM »
Yes, files.simutrans-germany.com, please. Thank you for the update - one bit of work less for me!

No Worries mate. I've uploaded the SVE for you, I've labeled it 3.4.2 because the site kept telling me the file already exists. Please take note of the two substations at the NW of Alice Springs. I've removed the power lines etc because the ST's were not needed, but I can't remove the ST's.

edit 11am today I've noticed that no matter where one builds a power station or a sustation etc one always gets the message 'No Suitable Ground' even though it still builds there.
« Last Edit: May 06, 2009, 01:00:43 AM by Colin »

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18690
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Experimental 3.4 crashes
« Reply #7 on: May 07, 2009, 08:50:43 PM »
Colin,

thank you for your bug reports, and your patience. I have been going through these one by one.

1. Rotating map crashes: I can reproduce this in your saved game, but I have not yet had success in tracking down the error. It appears to originate in code that has not been altered from Simutrans-Standard. Can you test to see whether you ever get a similar issue in the latest nightly builds of Simutrans-Standard, on which Simutrans-Experimental is based? Also, have you tried to see whether you can reproduce this error in paksets other than Pak64? Sometimes, map rotation crashes can be caused by rogue assets.

2. Substation removal crashes: That will be fixed in the next version of Simutrans-Experimental. Thank you for reporting it.

3. Crash when removing underground tracks: I have not been able to reproduce it, and it does not seem like the sort of issue that is specific to Simutrans-Experimental. Can you reproduce similar behaviour in the latest Simutrans-Standard nightlies?

4. "No suitable ground" message in error: That will be fixed in the next version of Simutrans-Experimental; thank you again for reporting it.

Thank you very much for your testing - I hope that you are enjoying playing Simutrans-Experimental!

Offline Colin

  • Devotees (Inactive)
  • *
  • Posts: 663
  • Certa Cito
Re: Experimental 3.4 crashes
« Reply #8 on: May 07, 2009, 10:11:48 PM »
Colin,

thank you for your bug reports, and your patience. I have been going through these one by one.

1. Rotating map crashes: I can reproduce this in your saved game, but I have not yet had success in tracking down the error. It appears to originate in code that has not been altered from Simutrans-Standard. Can you test to see whether you ever get a similar issue in the latest nightly builds of Simutrans-Standard, on which Simutrans-Experimental is based? Also, have you tried to see whether you can reproduce this error in paksets other than Pak64? Sometimes, map rotation crashes can be caused by rogue assets. My latest nightly is 2437 I haven't had any problems with that one I will download the latest today. I don't seem to have much time for Standard at the moment, too busy with yours.  8)

2. Substation removal crashes: That will be fixed in the next version of Simutrans-Experimental. Thank you for reporting it.You're very welcome

3. Crash when removing underground tracks: I have not been able to reproduce it, and it does not seem like the sort of issue that is specific to Simutrans-Experimental. Can you reproduce similar behaviour in the latest Simutrans-Standard nightlies?Again, I've had no problems with this with 2437.

4. "No suitable ground" message in error: That will be fixed in the next version of Simutrans-Experimental; thank you again for reporting it.Once again, you're very welcome, and THANK YOU for spending time fixing these things.

Thank you very much for your testing - I hope that you are enjoying playing Simutrans-Experimental!Yes I do but it's very hard for an addled brain like mine to get the 'Speed Bonus/Weight right.

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18690
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: Experimental 3.4 crashes
« Reply #9 on: May 07, 2009, 10:14:33 PM »
Colin,

thank you for your reply :-) Have a go with the latest release - 3.5 - which is out now, and let me know whether any of those problems are better for you. What exactly is the confusing you with the speed bonus and/or weight limits? It is helpful to know where people are confused when I come to write documentation.

Thank you again for your testing,

James

Offline Colin

  • Devotees (Inactive)
  • *
  • Posts: 663
  • Certa Cito
Re: Experimental 3.4 crashes
« Reply #10 on: May 07, 2009, 10:20:22 PM »
Colin,

thank you for your reply :-) Have a go with the latest release - 3.5 - which is out now, and let me know whether any of those problems are better for you. What exactly is the confusing you with the speed bonus and/or weight limits? It is helpful to know where people are confused when I come to write documentation.

Thank you again for your testing,

James

It's just me James, My brain won't get itself round the formulas, too old you see.

I've just dowloaded 3.5 and Standard 2449 I'll try them both today.