The International Simutrans Forum

 

Author Topic: [Bug?] No rail bridges, bus/stagecoach stop in victorian era  (Read 2510 times)

0 Members and 1 Guest are viewing this topic.

Offline AP

  • Devotee
  • *
  • Posts: 1202
  • Languages: EN
Can't seem to build rail bridges prior to 1900. This would seem to be a problem now that we have rivers carving up our maps... :) Although I note from the thread further down that there seems to be some progress on that front.

EDIT: The absence of a bus stop pre-1900 would also seem to be a problem -very hard to test the balance of passenger trains if you can't get people to the stations. The only stop is a "bus terminal" which requires an end-road situation - not that useful in trying to give coverage to a town.

« Last Edit: July 09, 2009, 09:39:02 PM by AP »

Offline The Hood

  • Moderator
  • *
  • Posts: 2889
  • pak128.Britain developer
Re: [Bug?] No rail bridges, bus/stagecoach stop in victorian era
« Reply #1 on: July 10, 2009, 07:35:45 AM »
Thanks for the report.  Can I also check if you are missing the road bridge as well, but you can build the aqueduct?

The sources (see SVN) should allow these at that time as there is no intro year or retire_year.  However I seem to recall a similar problem somewhere else where the game required an intro_year=1750 (just omitting intro_year didn't seem to do the trick) to make them appear with the timeline on.  I will investigate, and as I haven't managed a bugfix release yet due to uploading problems, I will include a fix in the release.
« Last Edit: July 10, 2009, 08:03:12 AM by The Hood »

Offline AP

  • Devotee
  • *
  • Posts: 1202
  • Languages: EN
Re: [Bug?] No rail bridges, bus/stagecoach stop in victorian era
« Reply #2 on: July 10, 2009, 08:37:00 PM »
That is correct. The only "bridge" buildable pre-1900 is the aquaduct.

[Unless I play without the "use chronolgy from year" start option, of  course]