The International Simutrans Forum

 

Author Topic: Problem with pak sources  (Read 2876 times)

0 Members and 1 Guest are viewing this topic.

Offline paco_m

  • *
  • Posts: 170
Problem with pak sources
« on: February 17, 2011, 12:40:14 PM »
Hi,
i downloaded the 128svn-export@1111 version somewhere from a thread in this subforum (can't find it right now) and I am having problems compiling the paks with makeobj ;)

All the cargo-ships graphics i opened have a size of 2000x500, 2000x750pixel and so on - this is not working because makeobj PAK128 expects multiples of 128 pixel, any solution or is there already a newer version with correct image sizes available?
Also the part of the image with background-colour (tried with mhz cement barge) has not the right size so it would be quite a lot of work to fix it and realign the vehicles and as somewhere must exist images in a compileable format I prefer asking here  ;D



Ok, problem solved - it has to be compiled using makeobj PAK250.
A readme-file included in the sources with such information would be nice



Mod note: please do not double-post. Edit your last comment instead.
~Fabio


« Last Edit: February 17, 2011, 01:56:59 PM by fabio »

Offline Zeno

  • ENASSA Designer
  • Devotee
  • *
  • Posts: 1997
    • Zeno's Simutrans Creations
  • Languages: ES, EN, CAT
Re: Problem with pak sources
« Reply #1 on: February 17, 2011, 03:27:03 PM »
You may like to know that airplanes also have a special size: 176px, so you must use makeobj pak176 on them in order to compile correctly.

Offline Djohaal

  • *
  • Posts: 71
Re: Problem with pak sources
« Reply #2 on: April 09, 2011, 02:11:10 AM »
I banged my head around a lot while trying to recompile the monorail files, it seems to chug at the monorail depot complaining "depot" is not a recognized building type. Is there some magic to make it work?

Offline Zeno

  • ENASSA Designer
  • Devotee
  • *
  • Posts: 1997
    • Zeno's Simutrans Creations
  • Languages: ES, EN, CAT
Re: Problem with pak sources
« Reply #3 on: April 09, 2011, 09:42:23 AM »
No magic. Depot should work.
Code: [Select]
Obj=building
Name=MonorailDepot
type=depot
waytype=monorail_track

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 9409
  • Languages: De,EN,JP
Re: Problem with pak sources
« Reply #4 on: April 11, 2011, 08:56:56 AM »
It will work if your makeobj is not too old. Only the newest makeobj can compile the newest features ...

Offline Djohaal

  • *
  • Posts: 71
Re: Problem with pak sources
« Reply #5 on: April 11, 2011, 08:13:11 PM »
Maybe I'm using an old makeobj. I'll give it a check later.  ;D