The International Simutrans Forum

 

Author Topic: monorail pillars clipping error  (Read 3160 times)

0 Members and 1 Guest are viewing this topic.

Offline uci

  • *
  • Posts: 120
  • Without owner
  • Languages: EN, RO
monorail pillars clipping error
« on: April 09, 2011, 06:49:31 AM »
Hope can be fixed.

Offline DirrrtyDirk

  • Devotees (Inactive)
  • *
  • Posts: 1253
  • JR 700 Series Shinkansen
  • Languages: EN,DE
Re: monorail pillars clipping error
« Reply #1 on: April 09, 2011, 11:19:05 AM »
No way to fix that, since ways are always drawn in the background of vehicles, regardless of the shape of the way. There is no "BackImage"/"FrontImage" parameter for ways, it's just "Image". So internally all ways are handled as flat roads or railroad tracks.

The only possible workaround would be to create the pillars (and part of the "track" - at least the parts that should cover the vehicles) as way-objects - requiring people to build both all the time. Yoshi did that for his Shonan Monorail - but it is a somewhat cumbersome solution.

Offline VS

  • Senior Plumber (Devotee)
  • Devotee
  • *
  • Posts: 4855
  • Vladimír Slávik
    • VS's Simutrans site
  • Languages: CS,EN
Re: monorail pillars clipping error
« Reply #2 on: April 09, 2011, 05:12:24 PM »
Thanks for the report! Unfortunately, as Dirk says, unless the program is extended, no reasonable thing to do with paks. (Not even draw_as_ding helps.)

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 9411
  • Languages: De,EN,JP
Re: monorail pillars clipping error
« Reply #3 on: April 11, 2011, 08:58:38 AM »
You could use an electricfication for the pillars ... This goes in front too.

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4555
  • Languages: EN, DE, AT
Re: monorail pillars clipping error
« Reply #4 on: April 11, 2011, 06:23:55 PM »
An implementation of way front images should not be that difficult.

Offline DirrrtyDirk

  • Devotees (Inactive)
  • *
  • Posts: 1253
  • JR 700 Series Shinkansen
  • Languages: EN,DE
Re: monorail pillars clipping error
« Reply #5 on: April 11, 2011, 10:25:21 PM »
You could use an electricfication for the pillars ... This goes in front too.

I had already mentioned that workaround  ;D


@Dwachs:

If we could maybe have front / back images for ways some day... could we then also get them for signals and roadsigns? You see, for left traffic, (or left signalling) scenarios, they are automatically drawn "wrongly", i.e. behind when they should be in front and vice versa.

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4555
  • Languages: EN, DE, AT
Re: monorail pillars clipping error
« Reply #6 on: April 12, 2011, 06:43:28 AM »
The code that computes the correct image for signals/roadsigns is one of the dirrrrtiest parts of the simutrans code :P

Offline Václav

  • Devotee
  • *
  • Posts: 3230
  • formerly VaclavMacurek
  • Languages: CZ, EN
Re: monorail pillars clipping error
« Reply #7 on: April 13, 2011, 09:20:07 PM »
You could use an electricfication for the pillars ... This goes in front too.
I know that inside pak128 is similar track - but it has pillar only behind track, itself - and over vehicle is electrification - but it would need to be re-made. I have planned to paint something like it - but I gave up.

Offline VS

  • Senior Plumber (Devotee)
  • Devotee
  • *
  • Posts: 4855
  • Vladimír Slávik
    • VS's Simutrans site
  • Languages: CS,EN
Re: monorail pillars clipping error
« Reply #8 on: May 05, 2012, 10:26:23 AM »
Ways now have front images... I'm keeping this open, then :)

Or how about fixing this in r854? Closed :D
« Last Edit: May 05, 2012, 11:18:25 AM by VS »