The International Simutrans Forum

 

Author Topic: [11.5] cannot upgrade last vehicle in convoy when using replacer  (Read 1100 times)

0 Members and 1 Guest are viewing this topic.

Offline ӔO

  • Devotees (Inactive)
  • *
  • Posts: 2345
  • Hopefully helpful
  • Languages: en, jp
When multiple vehicles are eligible for upgrade in a convoy, the last one in line cannot be upgraded when using the replacer.

Pretty simple to replicate. Build a convoy with multiple eligible vehicles, in this case class 47, and then when using replace, you should notice the last one cannot be upgraded.

Offline jamespetts gb

  • Simutrans-Extended project coordinator
  • Moderator
  • *
  • Posts: 18721
  • Cake baker
    • Bridgewater-Brunel
  • Languages: EN
Re: [11.5] cannot upgrade last vehicle in convoy when using replacer
« Reply #1 on: August 19, 2013, 11:54:46 PM »
Thank you for the report - found and fixed on the 11.x branch.