The International Simutrans Forum

 

Author Topic: [r7053 SDL] Graphical error in the crossing  (Read 2343 times)

0 Members and 1 Guest are viewing this topic.

Offline Yona-TYT ve

  • Devotee
  • *
  • Posts: 1237
    • Simutrans-BLOG
  • Languages: ES
[r7053 SDL] Graphical error in the crossing
« on: February 02, 2014, 09:00:51 PM »

Offline Yona-TYT ve

  • Devotee
  • *
  • Posts: 1237
    • Simutrans-BLOG
  • Languages: ES
Re: [r7053 SDL] Graphical error in the crossing
« Reply #1 on: February 03, 2014, 06:00:58 AM »
This only happens to the generate a map for the first time.

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4607
  • Languages: EN, DE, AT
Re: [r7053 SDL] Graphical error in the crossing
« Reply #2 on: February 03, 2014, 06:29:45 AM »
I think, this is the same bug as here

http://forum.simutrans.com/index.php?topic=13229.0

thus, should be fixed already in r7056.

Thanks for reporting.

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 5558
  • Languages: EN, NO
Re: [r7053 SDL] Graphical error in the crossing
« Reply #3 on: February 03, 2014, 06:33:03 AM »
There appears to be multiple graphical errors in this screen shot. At least one of which likely is an error in the pak graphics itself.

Offline Yona-TYT ve

  • Devotee
  • *
  • Posts: 1237
    • Simutrans-BLOG
  • Languages: ES
Re: [r7053 SDL] Graphical error in the crossing
« Reply #4 on: February 03, 2014, 07:14:50 AM »
There appears to be multiple graphical errors in this screen shot. At least one of which likely is an error in the pak graphics itself.


That pillar should be in front... :o

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4607
  • Languages: EN, DE, AT
Re: [r7053 SDL] Graphical error in the crossing
« Reply #5 on: February 03, 2014, 06:47:46 PM »
The missing pole is fixed, the other error (the railing overlapping the pole) is hard if not impossible to fix.

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 5558
  • Languages: EN, NO
Re: [r7053 SDL] Graphical error in the crossing
« Reply #6 on: February 03, 2014, 07:08:12 PM »
The third "error" is a grey bar apparently hovering in mid air.

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 9585
  • Languages: De,EN,JP
Re: [r7053 SDL] Graphical error in the crossing
« Reply #7 on: February 03, 2014, 10:09:51 PM »
Somehow in fast forward all ships are clipped to a single tile. Seems related to the cutted pylon.

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 5558
  • Languages: EN, NO
Re: [r7053 SDL] Graphical error in the crossing
« Reply #8 on: February 04, 2014, 05:31:21 AM »
Somehow in fast forward all ships are clipped to a single tile. Seems related to the cutted pylon.

I've noticed that sheep in pak64 are also clipped by tiles to the lower right, possibly also lower left. I don't know if that's related.

Offline Dwachs

  • DevTeam, Coder/patcher
  • Administrator
  • *
  • Posts: 4607
  • Languages: EN, DE, AT
Re: [r7053 SDL] Graphical error in the crossing
« Reply #9 on: February 14, 2014, 04:07:10 PM »
I've noticed that sheep in pak64 are also clipped by tiles to the lower right, possibly also lower left. I don't know if that's related.
The sheep problem should be fixed with r7067.