Author Topic: autoconf  (Read 1590 times)

0 Members and 1 Guest are viewing this topic.

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 8821
  • Total likes: 322
  • Helpful: 229
  • Languages: De,EN,JP
autoconf
« on: September 09, 2014, 11:30:04 PM »
I added in r7313 an autoconf file, so configure could work. Please test it on as many a platforms as you can.

Beware This will overwrite your existing config.default!

Offline R1dO

Re: autoconf
« Reply #1 on: September 10, 2014, 12:19:38 PM »
Not sure if intended.

The current configuration will always build the server version (e.g. posix and bit=0) if neither of the following options is given:
  • --enable-server
  • --enable-server=no
  • --disable-server
Due to default action of AC_ARG_ENABLE, see: autoconf documentation

If not intended it could be solved by changing
Code: [Select]
AC_ARG_ENABLE([server], [AS_HELP_STRING([--enable-server],[Builds a server without graphics])])to
Code: [Select]
AC_ARG_ENABLE([server], [AS_HELP_STRING([--enable-server],[Builds a server without graphics])], [], [enable_server=no])
Hope  it helps.

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 8821
  • Total likes: 322
  • Helpful: 229
  • Languages: De,EN,JP
Re: autoconf
« Reply #2 on: September 10, 2014, 08:53:53 PM »
Thank you very much. MY messing with autoconf was not very sucessfull. Especially the autoconf OS detect leads to non-working scripts on my Ubuntu (no install.sh found error).

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 4861
  • Total likes: 201
  • Helpful: 108
  • Languages: EN, NO
Re: autoconf
« Reply #3 on: September 11, 2014, 06:16:59 PM »
autoconf is one of those things I wonder if anybody really understands how to use (as opposed to just run it). I tried learning it once, and found virtually nothing. People just seem to copy each other, and tweak in the few things they need, whereas what they don't need stays. Some projects seem to spend more time autoconf-ing than compiling.

Offline Vladki

Re: autoconf
« Reply #4 on: September 11, 2014, 07:31:05 PM »
Tested on Debian 7 (wheezy) 32-bit. The generated config.default had config=SDL, and Make complained that it sdhould be sdl (lowercase). Otherwise seems OK.