The International Simutrans Forum

 

Author Topic: How to split roads without removing it?  (Read 553 times)

0 Members and 1 Guest are viewing this topic.

Offline Mishasama

  • *
  • Posts: 52
  • BE NICE
  • Languages: JA, ZH, EN
How to split roads without removing it?
« on: September 24, 2020, 09:06:04 PM »
Connecting roads has cost nothing, but how to split roads without cost?

Offline prissi

  • Developer
  • Administrator
  • *
  • Posts: 10528
  • Languages: De,EN,JP
Re: How to split roads without removing it?
« Reply #1 on: September 25, 2020, 05:24:46 AM »
Use the way remove tool and click as start on the left and as stop on ther end tile. This will only remove connected roads tiles.

Offline Vladki

  • Devotee
  • *
  • Posts: 3691
    • My addons, mostly roadsigns, pak128.cs
  • Languages: EN, CS
Re: How to split roads without removing it?
« Reply #2 on: September 25, 2020, 03:08:24 PM »
From my experience I recommend dragging the way remove tool, so you can see what will be deleted. An unexpected one way sign can wipe your whole railway network... And also a click may be often interpreted as a short drag  - within one tile, removing that tile.

Offline Mishasama

  • *
  • Posts: 52
  • BE NICE
  • Languages: JA, ZH, EN
Re: How to split roads without removing it?
« Reply #3 on: September 25, 2020, 06:03:28 PM »
Use the way remove tool and click as start on the left and as stop on ther end tile. This will only remove connected roads tiles.
Thank you!
From my experience I recommend dragging the way remove tool, so you can see what will be deleted. An unexpected one way sign can wipe your whole railway network... And also a click may be often interpreted as a short drag  - within one tile, removing that tile.
Yah... Dragging is better than clicking, it almost removing one tile every time.

Offline Ters

  • Coder/patcher
  • Devotee
  • *
  • Posts: 5688
  • Languages: EN, NO
Re: How to split roads without removing it?
« Reply #4 on: September 27, 2020, 08:42:41 AM »
I have sometimes had problems that the tool also removes all the roads on the start and from tile, even though there were other connections. I don't know if it is a bug (which also could be fixed by now), an unsteady hand, or both.